Watersnake Geo-Spot Bow Mount Motor Troubleshooting

< WATERSNAKE MOTOR SUPPORT


A significant number of issues can be caused by a disruption of power supplied to your Watersnake motor.  Careful inspection of your 12v deep cycle battery, wiring and set up should be completed before assuming that there is a fault with your motor. 


NO POWER / REDUCED POWER

NOTE –  Watersnake Bow Mount motors are fitted with a tilt switch that prevents the motor from running unless it is in the deployed (vertical) position.

  • Check that battery connection has not been reversed. (reversed polarity)
  • Check that your 12v deep cycle battery is fully charged. (+ 12v)
  • Check terminals / connections are secure and not loose.
  • Check terminals / connections for any signs of damage, corrosion or build up of debris.
  • If the battery cable has been extended but not replaced, you may be experiencing damaging voltage drop. Check this table to see if you have the correct gauge wire for the length of cable extension.
  • Remove propeller and check for any build up of fishing line / weed or any other debris.
  • Check that propeller pin (shear pin) is in place.
  • Armature or magnet cracked or dislodged – grinding noise will come from motor. Contact the Watersnake distributor in your region.

 NOISE OR VIBRATION COMING FROM MOTOR
  •  Check that propeller is securely tightened and shear pin is in place.
  • Remove propeller and check for any build up of fishing line / weed or any other debris.
  • Check that your 12v deep cycle battery is fully charged. (+ 12v)
  • If the problem is not resolved, contact the Watersnake distributor in your region.

 MOTOR WILL NOT RUN AT VARIABLE SPEEDS
  • Check that your 12v deep cycle battery is fully charged. (+ 12v)
  • Check terminals / connections are secure and not loose.
  • Check terminals / connections for any signs of damage, corrosion or build up of debris.
  • Ensure motor is on and remote battery has charge.
  • Power off both the Motor and Remote Fob and restart them.
  • If these potential issues and fixes do not solve the problem, contact the Watersnake distributor in your region.

 DIFFICULTY DEPLOYING OR STOWING MOTOR
  • Ensure you are using the correct deploy/stow process shown here.
  • Check for obstructions within the mounting assembly.
  • Lubricate shaft with spray lubricant. Concentrate spray on area where shaft runs through turnbox.
  • Clean any debris from the mounting bracket.
  • Remove the side covers from the mounting bracket and apply marine grease to moving parts of the stow/deploy mechanism.

MOTOR HAS DIFFICULTY STEERING
  • Check if coiled power lead from base to motor head is tangled/knotted around shaft. Stop, select Manual Mode and unravel or raise shaft from turnbox collar and manually rotate to disentangle.
  • Power off both the Motor and Remote Fob and restart them.
  • If these potential issues and fixes do not solve the problem, contact the Watersnake distributor in your region.

MOTOR WILL NOT STAY IN ANCHOR MODE
  • Check Remote display for GPS signal – top left 4 bars for signal quality. Restart Base Assembly and Remote to establish connectivity and satellite reception.
  • Check pairing of Remote and Base Assembly. With power on Remote and Base, press Pairing button on Base housing and await “shave and a haircut” pairing signal.
  • Check Anchor mode is engaged.
  • Check Anchor spot is within 1km of current position (distance should appear on Remote display).
  • Check battery has sufficient power (voltage appears on top line of Remote display).
  • Check coiled upper power lead for tangling.
  • Check in Remote/Menu/Settings/Boat size that it conforms with your craft.
  • Check current, wind, tide conditions are within operational parameters of motor. Motor is unable to hold position if wind/water conditions produce boat drift exceeding potential top speed of motor, eg, around 6kmh.
  • Power off both the Motor and Remote Fob and restart them.
  • If these potential issues and fixes do not solve the problem, contact the Watersnake distributor in your region.

REMOTE CONTROL
  • Blank remote screen – not operational – 3 x AAA batteries may need replacement. Phillips head screwdriver required.
  • Screen message “No Connection”:
    • Check Base Unit has powered up and status light shows GREEN
    • Try restarting base assembly processor and Remote control by powering off and restarting each.
    • Check pairing of remote with base unit by pressing left “Pairing” button on base when remote is on. “Shave-and-a-haircut” peeps indicate pairing established.
  • Error Messages: If an error message is displayed on the Remote Control FOB unit, an error has occurred with the motor control system. Please note the contents of the error message and/or photograph the FOB display message and contact Watersnake Service to receive more detailed instructions on how the problem can be resolved.

OPTIONAL FOOT CONTROL
  • Check that remote is selected for manual mode.
  • Check that foot control cable plug is firmly connected and locked in.
  • Check for debris that may affect operation of pedal controls and cable connections.
  • Check speed control dial is not set to zero.
  • Restart base unit and recheck.

STILL HAVING MOTOR ISSUES?

If the tips above do not resolve your motor issue, please contact the Watersnake distributor in your region. They can help diagnose more serious issues and help with spare parts and repairs.